Problem bei Passieren Hudson Variable als JMeter Befehlszeilenargument

stimmen
0

Als ich versuchte , die hudson Variable vorbei (ARBEITSBEREICH) als Linie Jmeter Befehlsargumente wie -Jworkspace=${WORKSPACE}druckt Jmeter Skript den Wert , wie es ist. Ich sehe Ausgabe als${WORKSPACE}

Wie behebe ich das?

Veröffentlicht am 24/11/2015 um 12:52
vom benutzer
In anderen Sprachen...                            


1 antworten

stimmen
0

Der richtige Weg, um einen OS-Umgebungsvariable als Parameter an einen Java-Prozess zu verwenden ist:

-Denv_var=%MY_ENV_VAR% (Windows)
-Denv_var=$MY_ENV_VAR (Linux)

In Ihrem Fall, vorausgesetzt, Sie auf Linux sind,

-Jworkspace=$WORKSPACE

Dies würde nur funktionieren, wenn WORKSPACEbereits eine definierte Umgebungsvariable. Überprüfen Sie, indem Sie echo $WORKSPACEauf dem Linux - Kommandozeile.

Sie können auch OS Umgebungsvariablen innerhalb JMeter (oder eine beliebige Java-Prozess wirklich) zugreifen, als System.getenv("MY_ENV_VAR");

Beantwortet am 24/11/2015 um 15:05
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more