Gibt es trotzdem entzwei Modul in Python 3 zu installieren

stimmen
1

Ich mag die Installation Python TWAIN - Modul in Python 3. Aber in der Dokumentation heißt es:

Python-Versionen 2.1 bis 2.5 werden unterstützt.

Kann ich wandeln es mit 2to3?

Veröffentlicht am 12/01/2016 um 13:06
vom benutzer
In anderen Sprachen...                            


1 antworten

stimmen
0

Verwenden letzte Modul , das ein experimentelles Übersetzungspaket bietet mit dem Import und Verwendung von alter Python 2 Module in einer Python - 3 - Umgebung zu helfen.

So installieren Sie Ihr Paket mit pip

pip3 install twain --no-compile   # to ignore SyntaxErrors

Und im nächsten Code verwendet entzwei in Ihrem importieren python3Code:

from past import autotranslate
autotranslate(['twain'])

import twain


# use twain ....... 
Beantwortet am 12/01/2016 um 13:13
quelle vom benutzer

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more